v0.43 / Administration Guide / Supported browsers

Supported browsers

We try our best to make sure Metabase works in as many browsers as possible, but as this is the Internet, there may be little quirks from time to time in different settings. We believe Metabase works on these versions of these browsers and will attempt to fix specific bugs if any are found:

  • Chrome (v70+)
  • Firefox (v68+)
  • Microsoft Edge (v17+)
  • Safari (v11+)

Metabase may run perfectly well on older versions of these browsers or on specific browsers not listed above, but your mileage may vary. In particular, we ended support for IE11 in Metabase 0.40: it mostly still works, but you may see some unexpected behavior.

We recommend you use the most up-to-date browser you can.